Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

Problem with stopping activities.

Riaff1 — May 15, 2015 11:17PM BST

Hi. I've been having a lot of problems lately with stopping an activity. What happens is this. I'll start Map My Tracks just before I start my ride. Ride for a couple hours, get home and stop MMT (Map My Tracks). After pressing both stop buttons the activity disappears. No record of it on my phone and not on the website because I never had a chance to sync it. So, couple more times of this happening I figure maybe I'm riding too long and it looses my signal, something like that or some weird thing and that's the reason it's not able to stop the activity. So I shorten intervals between stopping and syncing during my longer rides figuring that'll solve any problems. Nope. Still, random whether it'll stop properly. Sometimes I can ride for 50 minutes try to stop it and it works sometimes not.

The weird thing is, and it's done this a couple times now, sometimes after it's not stopped properly and disappears it'll show up after I start a new activity a day or two later then combine the two rides and come out with some ridiculous stats for the ride.

I figure I've lost over 2 hundred KM's because of my activities disappearing when I try to stop them and I'm getting really frustrated with MMT.

Any one have an idea what could be causing this and how to fix it?? Any help would be great.


10 Community Answers

Nick - May 16, 2015 at 07:19PM BST

Map My Tracks team member

Thanks for the detailed feedback. It does not sound like normal behaviour and I can imagine the frustration that this causes. Out of interest, what phone are you using?

We'll review the process and see if we can identify what might be causing this.

rated : 0 Up Down

Riaff1 - May 18, 2015 at 01:14AM BST

I'm using an iPhone 4 with the latest updates. I've read some other posters with problems that have removed the Ap from their phone and re-installed it again. Should I be looking to do this?

Thanks for your reply :)

Brian

rated : 0 Up Down

Nick - May 18, 2015 at 09:24AM BST

Map My Tracks team member

You should not need to reinstall the app but you can do so if you wish.

Before you delete the app please make sure you have synced all your data online. Then when you reinstall the app you will need to manually sync back any data you want on your phone.

We are in the middle of an iOS update so we will investigate the issue you have reported and see if we can pin down the problem.

rated : 0 Up Down

Rob - May 18, 2015 at 11:37AM BST

Map My Tracks team member

Hi,
Can I ask a few more questions, please?
When you stop a track that disappears, do you see the track review page or are you taken directly back to the app dashboard after tapping stop? If you see the track review page, what data is presented on it?
Also, when you start a track and find a previously tracked activity appended to it, do you have to press the green start button or is the app already tracking when the tracking page is presented?

Thanks again for your continued feedback.
Regards,
Rob

rated : 0 Up Down

Carsten B Pedersen - May 18, 2015 at 02:04PM BST

Hi

I have had exactly the same problems on my Iphone 5 with latest updates. I have only observed this during the past weeks, so likely a result of some updates from Apple which is not totally compatible with mapmytracks.

PS. Before the app crashes it showed the activity time shortly.


Bw, Carsten

rated : 0 Up Down

Riaff1 - May 19, 2015 at 01:09AM BST

Hi Nick. Thanks, I'll do the syncs prior to un-installing it.

Hi Rob. When I stop a track that disappears it takes me right back to the dashboard. I then have to set up another track, ie: restart, let MMT acquire gps until it says ready, etc. There's no rhyme or reason for the tracks that come back and merge with others.

I have a track that I've been hesitant to sync as it has the strangest data on it and would mess with my pace times. I'll post it and if you'd like have a look at it. It's dated 5th of May and has a distance of 22.8 KM's on it. The first part of the track is a 60 km loop. I was tracking the whole thing (no breaks between stopping and syncing). It disappeared when I tried to stop it when I finished the 60 KM ride and it merged with the 22 KM leg of a ride I started a couple days later. It wasn't there when I started the track for the ride 2 days later it just was somehow added to it after I stopped the track at 22 km.

I'm going to try un-installing the app then re-installing it as something new has happened just when I went to sync that track mentioned above. I don't know how this happened but when I went into my history there was a new track at the top (latest one) that had a completed date of 31 Dec with a distance of 15 KM and total calories burned for that track 143,575,688. I won't sync that one as I don't won't to take over the most calories burned in all map my tracks with one ride, lol.

Thanks again for your reply's.

Brian

rated : 0 Up Down

Ian - May 22, 2015 at 04:02AM BST

Maybe turn off Auto resume.

rated : 0 Up Down

Riaff1 - May 30, 2015 at 04:08PM BST

Well, i tried what Ian mentioned, turn off the Auto resume, and i haven't had any problems since. I've done 7 tracks since turning it off one of which was one and a 1/4 hours. I'll been trying longer rides without stopping to stop MMT and see how it goes but so far turning off Auto resume seems to have worked.

Brian

rated : 0 Up Down

Dan - Jun 01, 2015 at 05:06AM BST

I've been having similar issues as well. Lost my best track yet today. I can't use mapmytracks because of this?

Here's an example of 2 rides mushed together, if you look at some of the charts you can see the 24+ hour span across the 2 activities:

http://www.mapmytracks.com/explore/activity/1861187

rated : 0 Up Down

Dan - Jun 19, 2015 at 07:33AM BST

No issue since last iOS update?

rated : 0 Up Down

This question has received the maximum number of answers.